InputLabelProps Interface

Deprecated  in 4.12.0. Props of deprecated component InputLabel.

Properties for InputLabel components

Extends

Properties

Name Type Description
children React.ReactNode | undefined Labeled content  
disabled boolean | undefined    

Inherited properties

Name Type Inherited from Description
className Inherited string | undefined CommonProps Custom CSS class name
inputClassName Inherited string | undefined LabeledComponentProps Custom CSS class name for the checkbox input element
inputStyle Inherited React.CSSProperties | undefined LabeledComponentProps Custom CSS Style for the checkbox input element
itemId Inherited string | undefined CommonProps Optional unique identifier for item.
label Inherited string | undefined LabeledComponentProps Text that will be shown next to or above the input.
labelClassName Inherited string | undefined LabeledComponentProps Custom CSS class name for the label
labelStyle Inherited React.CSSProperties | undefined LabeledComponentProps Custom CSS Style for the label
message Inherited string | undefined MessagedComponentProps Optional text shown below the input.
messageClassName Inherited string | undefined MessagedComponentProps Custom CSS class name for the message
messageStyle Inherited React.CSSProperties | undefined MessagedComponentProps Custom CSS Style for the message
status Inherited InputStatus | undefined LabeledComponentProps Input status like: "Success", "Warning" or "Error"
style Inherited React.CSSProperties | undefined CommonProps Custom CSS style properties

Defined in

Last Updated: 30 January, 2025