MessageBoxProps Interface
Deprecated in 4.15.0. Props of deprecated MessageBox component.
Properties for the MessageBox component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
buttonCluster | DialogButtonDef[] | List of DialogButtonDef objects specifying buttons and associated onClick events | |
children | React.ReactNode | undefined | Message content | |
contentClassName | string | undefined | Custom CSS class name for the content | |
contentStyle | React.CSSProperties | undefined | Custom CSS Style for the content | |
height | string | number | initial height of dialog. | |
minHeight | number | undefined | minimum height that the dialog may be resized to. | |
minWidth | number | undefined | minimum width that the dialog may be resized to. | |
modal | boolean | undefined | Whether to show background overlay. | |
onClose | () => void | undefined | onClick event for X button for dialog | |
onEscape | () => void | undefined | 'keyup' event for |
|
opened | boolean | whether to show dialog or not | |
severity | MessageSeverity | Severity of MessageBox | |
title | string | React.ReactElement<any, string | React.JSXElementConstructor<any>> | Title to show in title bar of dialog | |
width | string | number | initial width of dialog. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.