DialogProps Interface
Deprecated in 4.12.0. Props of deprecated component Dialog.
Properties for the Dialog component
Extends
- Omit<React.AllHTMLAttributes<HTMLDivElement>, "title">
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
alignment | DialogAlignment | undefined | Default alignment of dialog. | |
backgroundStyle | React.CSSProperties | undefined | Custom CSS Style for overlay | |
buttonCluster | DialogButtonDef[] | undefined | List of DialogButtonDef objects specifying buttons and associated onClick events | |
contentClassName | string | undefined | Custom CSS class name for the content | |
contentStyle | React.CSSProperties | undefined | Custom CSS Style for the content | |
footer | string | React.ReactElement<any, string | React.JSXElementConstructor<any>> | Footer to show at bottom of dialog. | |
footerStyle | React.CSSProperties | undefined | Custom CSS Style for footer | |
header | React.ReactNode | undefined | Override for the header | |
height | string | number | Initial height of dialog. | |
hideHeader | boolean | undefined | Whether the hide the header. | |
inset | boolean | undefined | Indicates whether the content should be inset. | |
maxHeight | string | number | Maximum height that the dialog may be resized to. | |
maxWidth | string | number | Maximum width that the dialog may be resized to. | |
minHeight | string | number | Minimum height that the dialog may be resized to. | |
minWidth | string | number | Minimum width that the dialog may be resized to. | |
modal | boolean | undefined | Whether to show background overlay. | |
modelessId | string | undefined | An id for a modeless dialog | |
movable | boolean | undefined | Indicates whether the user can move dialog with cursor. | |
onClose | () => void | undefined | onClick event for X button for dialog | |
onEscape | () => void | undefined | 'keyup' event for Esc key | |
onModelessPointerDown | (event: React.PointerEvent<Element>, id: string) => void | undefined | Pointer Down event handler when modeless (modal = false) | |
onOutsideClick | (event: MouseEvent) => any | undefined | Triggered when a click is triggered outside of this dialog. | |
opened | boolean | Indicates whether to show dialog or not | |
resizable | boolean | undefined | Indicates whether the user can resize dialog with cursor. | |
title | string | React.ReactElement<any, string | React.JSXElementConstructor<any>> | Title to show in title bar of dialog | |
titleStyle | React.CSSProperties | undefined | Custom CSS Style for title | |
trapFocus | boolean | undefined | Indicates whether the focus should be trapped within the dialog. | |
width | string | number | Initial width of dialog. | |
x | number | undefined | Initial x/left position of dialog in px. | |
y | number | undefined | Initial y/top position of dialog in px. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.