MutableFormatsProvider Interface
This interface is implemented by a class that would provide and allow creating formats for use in formatting quantities.
Extends
Methods
Name | Description | |
---|---|---|
addFormat(name: string, format: FormatDefinition): Promise<void> | ||
removeFormat(name: string): Promise<void> |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getFormat(name: string): Promise<undefined | FormatDefinition> Inherited | FormatsProvider |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onFormatsChanged Inherited | BeEvent<(args: FormatsChangedArgs) => void> | FormatsProvider |
Defined in
- quantity/src/Formatter/Interfaces.ts Line 134
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.