HalfEdgePositionDetail Class
Description of a generalized position within a graph, categorized as:
- "at a certain node around a vertex"
- "at a fractional position along an edge"
- "within a face"
Methods
Name | Description | |
---|---|---|
clonePoint(result?: Point3d): Point3d | Return the (clone of, or optional filled in result) coordinates from this detail. | |
getDTag(): undefined | number | ||
getITag(): undefined | number | ||
getTopo(): HalfEdgeTopo | ||
isAtXY(x: number, y: number): boolean | ||
resetAsFace(node?: , xyz?: Readonly<WritableXYAndZ>): HalfEdgePositionDetail | Reassign contents so this instance becomes a face hit. | |
resetAsUndefinedWithTag(dTag: number): HalfEdgePositionDetail | Reassign contents so this instance has dTag but no node or HalfEdgeTopo. | |
resetAsUnknown(): void | Reset to null topo state. | |
resetAsVertex(node: ): HalfEdgePositionDetail | Mark as "HalfEdgeTopo.Vertex". | |
resetAtEdgeAndFraction(node: , edgeFraction: number): HalfEdgePositionDetail | Reassign contents so this instance becomes an edge hit. | |
setDTag(value: number): void | ||
setFrom(other: HalfEdgePositionDetail): void | Copy (clones of) all data from other. | |
setIsExteriorTarget(isExterior: boolean): void | Set the flag for an exterior relationship to target. | |
setITag(value: number): void | ||
setXYZFromNode(node: ): void | Copy x,y,z from the node to this instance local values. | |
create(): HalfEdgePositionDetail Static | Create with null data. | |
createEdgeAtFraction(node: , edgeFraction: number): HalfEdgePositionDetail Static | Create with node, fraction along edge, marked as "HalfEdgeTopo.Edge". | |
createVertex(node: ): HalfEdgePositionDetail Static | Create at a node. |
Properties
Name | Type | Description | |
---|---|---|---|
edgeFraction Accessor ReadOnly | undefined | number | Return the (possibly undefined) edge fraction. | |
isEdge Accessor ReadOnly | boolean | Return true if this detail is marked as being within an edge. | |
isExteriorTarget Accessor ReadOnly | boolean | Property access for the flag for an exterior relationship to target. | |
isFace Accessor ReadOnly | boolean | Return true if this detail is marked as being within a face. | |
isUnclassified Accessor ReadOnly | boolean | Return true if this detail has no vertex, edge, or face qualifier. | |
isVertex Accessor ReadOnly | boolean | Return true if this detail is marked as being at a vertex. | |
node Accessor ReadOnly | undefined | | Return the node reference from this detail | |
x | number | The current coordinates. | |
y | number | ||
z | number |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.