HalfEdgePointerInspector Class
HalfEdgePointerInspector has methods to check HalfEdge objects for pointer errors.
- For a one-step test of the whole graph.
Methods
Name | Description | |
---|---|---|
constructor(): HalfEdgePointerInspector | ||
clearCounts(): void | Clear all counts. | |
inspectHalfEdge(he: ): void | Inspect a single half edge. | |
inspectHalfEdges(graph: ): void | Inspect all half edges of graph. | |
inspectGraph(graph: , expectAllMates: boolean): boolean Static | Inspect a graph's pointer properties. |
Properties
Name | Type | Description | |
---|---|---|---|
isValidClosedHalfEdgeGraph Accessor ReadOnly | boolean | Return true if all pointer pairings are correct for a closed half edge graph (with no boundary): | |
isValidHalfEdgeGraphAllowRaggedBoundary Accessor ReadOnly | boolean | Return true if all pointer pairings are correct for a half edge graph with possible boundary: | |
numFSFPError | number | ||
numMatePairError | number | ||
numTested | number | ||
numUndefinedEdgeMate | number | ||
numUndefinedFP | number | ||
numUndefinedFS | number | ||
numWithMatchedEdgeMate | number |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.