create MethodStatic
Create a rotational sweep.
create(contour: AnyCurve, axis: Ray3d, sweepAngle: Angle, capped: boolean): undefined | RotationalSweep
Parameter | Type | Description |
---|---|---|
contour | AnyCurve | profile to sweep, coplanar with axis (CAPTURED). |
axis | Ray3d | rotation axis. |
sweepAngle | Angle | signed angular sweep. |
capped | boolean | whether to cap the surface to make a solid. |
Returns - undefined | RotationalSweep
Defined in
- solid/RotationalSweep.ts Line 53
Last Updated: 04 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.