RangeLengthData Class
Accumulated data for x,y,z length statistics in ranges.
- Usage pattern:
- create a enw RangeLengthData:
myData = new RangeLengthData ();
- announce ranges to be accumulated:
- (many times) `myData.accumulateRowableXYZArrayRange (points);
- access data in public members:
myData.range
-- the composite range.myData.xLength
,myData.yLength
,myData.zLength
-- mean, minMax, count, and standardDeviation of range lengths in x,y,z directions.
- create a enw RangeLengthData:
Methods
Name | Description | |
---|---|---|
constructor(): RangeLengthData | ||
accumulateGrowableXYZArrayRange(points: GrowableXYZArray): void | Extend the range and length sums by the range of points in an array. |
Properties
Name | Type | Description | |
---|---|---|---|
range | Range3d | Overall range of all data observed by accumulate methods. |
|
xSums | |||
ySums | |||
zSums |
Defined in
- polyface/RangeLengthData.ts Line 25
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.