Point3dArrayRangeTreeContext Class
Handler class for searching a range tree containing unordered Point3d data.
- Facilitates multiple searches for closest point and close approach calculations.
Methods
Name | Description | |
---|---|---|
searchForClosestPoint(spacePoint: Point3d, maxDist?: number): undefined | CurveLocationDetail | CurveLocationDetail[] | Search the range tree for closest point(s) to spacePoint. | |
createCapture(points: Point3d[], maxChildPerNode: number4, maxAppDataPerLeaf: number4): undefined | Point3dArrayRangeTreeContext Static | Create a range tree context with given points: | |
searchForClosestApproach(contextA: Point3dArrayRangeTreeContext, contextB: Point3dArrayRangeTreeContext, maxDist?: number): undefined | CurveLocationDetailPair | CurveLocationDetailPair[] Static | Search the range trees for closest approach(es) between the point arrays. |
Properties
Name | Type | Description | |
---|---|---|---|
numPointTest | number | Diagnostic: number of point distance tests | |
numRangeTestFalse | number | Diagnostic: number of range tests returned false | |
numRangeTestTrue | number | Diagnostic: number of range tests returned true | |
numSearch | number | Diagnostic: number of searches | |
points | Point3d[] | Array of points being searched, indexed by the range tree |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.