reverseIndicesSingleFacet Method
Reverse the indices for the specified facet in the index arrays (pointIndex, normalIndex, paramIndex, colorIndex, and edgeVisible).
reverseIndicesSingleFacet(facetIndex: number, facetStartIndex: number[]): void
Parameter | Type | Description |
---|---|---|
facetIndex | number | index of the facet to reverse. The entries of each index array to be reversed are found atfacetStartIndex[facetIndex] <= i < facetStartIndex[facetIndex + 1] . |
facetStartIndex | number[] | start indices of consecutive facets, e.g., an IndexedPolyface's _facetStart array. See reverseIndices. |
Returns - void
Defined in
- polyface/PolyfaceData.ts Line 679
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.