reverseIndices Method
Reverse the indices for the specified facets in the index arrays (pointIndex, normalIndex, paramIndex, colorIndex,
and edgeVisible).
reverseIndices(facetStartIndex?: number[]): void
Parameter |
Type |
Description |
facetStartIndex |
number[] |
start indices of consecutive facets to be reversed. * Consecutive indices in this array define where a given facet is represented in each of the parallel index arrays. * The indices for facet k are facetStartIndex[k] up to (but not including) facetStartIndex[k + 1] . * This implies facetStartIndex[k + 1] is both the upper limit of facet k's indices, and the start index of facet k+1. * For example, passing an IndexedPolyface's _facetStart array into this method reverses every facet. |
Returns - void
Defined in
Last Updated: 21 November, 2024