PolyfaceClip Class
PolyfaceClip is a static class gathering operations using Polyfaces and clippers.
Methods
Name | Description | |
---|---|---|
constructor(): PolyfaceClip | ||
clipPolyface(polyface: Polyface, clipper: ClipPlane | ConvexClipPlaneSet): undefined | Polyface Static | Clip each facet of polyface to the ClipPlane or ConvexClipPlaneSet | |
clipPolyfaceClipPlane(polyface: Polyface, clipper: ClipPlane, insideClip: booleantrue, buildClosureFaces: booleanfalse): IndexedPolyface Static | Clip each facet of polyface to the ClipPlane. | |
clipPolyfaceClipPlaneWithClosureFace(polyface: Polyface, clipper: ClipPlane, insideClip: booleantrue, buildClosureFaces: booleantrue): IndexedPolyface Static | Clip each facet of polyface to the ClipPlane. | |
clipPolyfaceConvexClipPlaneSet(polyface: Polyface, clipper: ConvexClipPlaneSet): IndexedPolyface Static | Clip each facet of polyface to the ClipPlane. | |
clipPolyfaceInsideOutside(polyface: Polyface, clipper: ClipPlane | ConvexClipPlaneSet | UnionOfConvexClipPlaneSets, destination: ClippedPolyfaceBuilders, outputSelect: number0): void Static | Clip each facet of polyface to the ClipPlane or ConvexClipPlaneSet | |
clipPolyfaceUnderOverConvexPolyfaceIntoBuilders(visitorA: PolyfaceVisitor, visitorB: PolyfaceVisitor, builderAUnderB: PolyfaceBuilder, builderAOverB: PolyfaceBuilder): void Static | * Split facets of mesh "A" into parts that are | |
clipPolyfaceUnionOfConvexClipPlaneSetsToBuilders(polyface: PolyfaceVisitor | Polyface, allClippers: UnionOfConvexClipPlaneSets, destination: ClippedPolyfaceBuilders, outputSelector: number1): void Static | Clip each facet of polyface to the the clippers. | |
computeCutFill(meshA: IndexedPolyface, meshB: IndexedPolyface): { meshAOverB: IndexedPolyface, meshAUnderB: IndexedPolyface } Static | * Split facets into vertically overlapping sections | |
drapeRegion(mesh: PolyfaceVisitor | Polyface, region: AnyRegion, sweepVector?: Vector3d, options?: StrokeOptions): undefined | IndexedPolyface Static | Drape the region onto the mesh. | |
sectionPolyfaceClipPlane(polyface: Polyface, clipper: ClipPlane): LineString3d[] Static | Intersect each facet with the clip plane. |
Defined in
- polyface/PolyfaceClip.ts Line 96
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.