createAtFacetIndex MethodStatic
Create a walker for a given polyface at a specified facet.
- If
facetIndex
oroffsetWithinFacet
is invalid for the input polyface, the walker returns true for isUndefined.
createAtFacetIndex(polyface: IndexedPolyface, facetIndex: number, offsetWithinFacet: number0): IndexedPolyfaceWalker
Parameter | Type | Description |
---|---|---|
polyface | IndexedPolyface | the polyface to reference |
facetIndex | number | index of the facet to reference |
offsetWithinFacet | number | optional 0-based offset within the face loop of the facet (default 0). This allows the caller to start the walker at a particular edge of the facet. |
Returns - IndexedPolyfaceWalker
Defined in
- polyface/IndexedPolyfaceWalker.ts Line 135
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.