createAtEdgeIndex MethodStatic
Create a walker for a given polyface at an optional edge.
createAtEdgeIndex(polyface: IndexedPolyface, edgeIndex?: number): IndexedPolyfaceWalker
Parameter | Type | Description |
---|---|---|
polyface | IndexedPolyface | reference to the client polyface. This reference is captured (the polyface is not copied). |
edgeIndex | number | optional indication of where to start the walker within the mesh. * If the edgeIndex is valid for the input polyface, the new walker is started there. * If the edgeIndex is undefined or invalid for the input polyface, the walker returns true for isUndefined. |
Returns - IndexedPolyfaceWalker
Defined in
- polyface/IndexedPolyfaceWalker.ts Line 121
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.