edgeIndexToFaceLoop Method
Given an edgeIndex (index into data.pointIndex
), return the range of the edgeIndices of the containing facet.
- A "face loop" is a contiguous block of edgeIndices in the polyface index arrays representing a facet.
- If an edge with edgeIndex
k
is found in the facet with facetIndexf
, then the returned ranger
satisfiesr.low = this.facetIndex0(f) <= k < this.facetIndex1(f) = r.high
and can be used to iterate the facet's face loop, e.g.:for (let k1 = r.low; k1 < r.high; k1++) { const edgeIndex = myPolyface.data.pointIndex[k1]; // process this edge }
edgeIndexToFaceLoop(k: number): undefined | Range1d
Parameter | Type | Description |
---|---|---|
k | number |
Returns - undefined | Range1d
Defined in
- polyface/Polyface.ts Line 181
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.