facetIndex0 Method
Given a valid facet index, return the index at which its face loop starts in the index arrays.
- A "face loop" is a contiguous block of indices into the parallel polyface index arrays.
- Each of these indices represents an edge of a facet, thus it is sometimes called an "edgeIndex".
- Together with facetIndex1, this method can be used to iterate the face loop of the facet
with index
iFacet
as follows:for (let iEdge = this.facetIndex0(iFacet); iEdge < this.facetIndex1(iFacet); iEdge++) { const iPoint = this.data.pointIndex[iEdge]; const p = this.data.point[iPoint]; // ... process the edge of this facet starting at point p }
facetIndex0(facetIndex: number): number
Parameter | Type | Description |
---|---|---|
facetIndex | number |
Returns - number
Defined in
- polyface/Polyface.ts Line 620
Last Updated: 04 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.