FacetIntersectOptions Class
Options for computing and processing facet intersection methods.
@see intersectRay3d
Methods
Name | Description | |
---|---|---|
constructor(): FacetIntersectOptions | constructor with defaults |
Properties
Name | Type | Description | |
---|---|---|---|
acceptIntersection | FacetIntersectCallback | undefined | optional callback to accept an intersected facet | |
distanceTolerance | number | distance tolerance for testing coincidence with facet boundary | |
needBarycentricCoordinates | boolean | undefined | whether to compute the barycentric coordinates of the point for a convex facet | |
needColor | boolean | undefined | whether to compute the color at the intersection point | |
needNormal | boolean | undefined | whether to compute the normal at the intersection point | |
needParam | boolean | undefined | whether to compute the uv parameter at the intersection point | |
parameterTolerance | number | fractional tolerance for snapping barycentric coordinates to a triangular facet edge |
Defined in
- polyface/FacetLocationDetail.ts Line 31
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.