ray3dXYZUVWClosestApproachUnbounded MethodStatic
Return true if the given rays have closest approach (go by each other) in 3d Return the fractional (not xy) coordinates as x and y parts of a Point2d.
ray3dXYZUVWClosestApproachUnbounded(ax: number, ay: number, az: number, au: number, av: number, aw: number, bx: number, by: number, bz: number, bu: number, bv: number, bw: number, result: Vector2d): boolean
Parameter | Type | Description |
---|---|---|
ax | number | x-coordinate of the origin of the first ray |
ay | number | y-coordinate of the origin of the first ray |
az | number | z-coordinate of the origin of the first ray |
au | number | x-coordinate of the direction vector of the first ray |
av | number | y-coordinate of the direction vector of the first ray |
aw | number | z-coordinate of the direction vector of the first ray |
bx | number | x-coordinate of the origin of the second ray |
by | number | y-coordinate of the origin of the second ray |
bz | number | z-coordinate of the origin of the second ray |
bu | number | x-coordinate of the direction vector of the second ray |
bv | number | y-coordinate of the direction vector of the second ray |
bw | number | z-coordinate of the direction vector of the second ray |
result | Vector2d | point to receive fractional coordinates of intersection. result.x is fraction on line a. result.y is fraction on line b. |
Returns - boolean
Defined in
- numerics/SmallSystem.ts Line 250
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.