linearSystem2d MethodStatic
Solve the pair of linear equations
ux * x + vx * y = cx
uy * x + vy * y = cy
linearSystem2d(ux: number, vx: number, uy: number, vy: number, cx: number, cy: number, result: Vector2d): boolean
Parameter | Type | Description |
---|---|---|
ux | number | xx coefficient |
vx | number | xy coefficient |
uy | number | yx coefficient |
vy | number | yy coefficient |
cx | number | x right hand side |
cy | number | y right hand side |
result | Vector2d | (x,y) solution (MUST be preallocated by caller) |
Returns - boolean
Defined in
- numerics/SmallSystem.ts Line 278
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.