StrokeCountChain Class
class StrokeCountChain
contains:
maps
= an array ofStrokeCountMap
parent
= parent CurveCollection.
An instance is normally created with either a Path
or Loop
as the parent.
Methods
Name | Description | |
---|---|---|
applySummed01Limits(incomingSum: number): number | walk the maps in the array. | |
getStrokes(): LineString3d | ||
createForCurveChain(chain: CurveChain, options?: StrokeOptions): StrokeCountChain Static |
Properties
Name | Type | Description | |
---|---|---|---|
maps | StrokeCountMap[] | ||
options | StrokeOptions | undefined | options are used (with different purposes) at two times: | |
parent | CurveCollection | undefined |
Defined in
- curve/Query/StrokeCountChain.ts Line 164
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.