createFilletsInLineString MethodStatic
Construct a sequence of alternating lines and arcs with the arcs creating tangent transition between consecutive edges.
- If the radius parameter is a number, that radius is used throughout.
- If the radius parameter is an array of numbers,
radius[i]
is applied atpoint[i]
.- Note that since no fillet is constructed at the initial or final point, those entries in
radius[]
are never referenced. - A zero radius for any point indicates to leave the as a simple corner.
- Note that since no fillet is constructed at the initial or final point, those entries in
createFilletsInLineString(points: IndexedXYZCollection | Point3d[] | LineString3d, radius: number | number[], allowBackupAlongEdge: booleantrue): undefined | Path
Parameter | Type | Description |
---|---|---|
points | IndexedXYZCollection | Point3d[] | LineString3d | point source |
radius | number | number[] | fillet radius or array of radii indexed to correspond to the points. |
allowBackupAlongEdge | boolean | true to allow edges to be created going "backwards" along edges if needed to create the blend. |
Returns - undefined | Path
Defined in
- curve/CurveFactory.ts Line 128
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.