CurveExtendOptions Class
Logic for deciding how a curve may be extended for closest point or intersection searches.
Methods
Name | Description | |
---|---|---|
constructor(): CurveExtendOptions | ||
correctFraction(extendParam: VariantCurveExtendParameter, fraction: number): number Static | Correct fraction to be within [0,1]. | |
resolveRadiansToSweepFraction(extendParam: VariantCurveExtendParameter, radians: number, sweep: AngleSweep): number Static | Adjust a radians value to an angle sweep, allowing the extendParam to affect choice among periodic fractions. | |
resolveVariantCurveExtendParameterToCurveExtendMode(param: VariantCurveExtendParameter, endIndex: "0" | "1"): CurveExtendMode Static | Given a VariantCurveExtendParameter , isolate the particular CurveExtendMode in effect at an end. |
Defined in
- curve/CurveExtendMode.ts Line 29
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.