closestPoint Method
Return the closest point on the contained curves.
closestPoint(spacePoint: Point3d, extend: VariantCurveExtendParameterfalse, result?: CurveLocationDetail): undefined | CurveLocationDetail
@returns details of the closest point.
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | point in space. |
extend | VariantCurveExtendParameter | applicable only to children of type CurvePrimitive, Path, or BagOfCurves |
result | CurveLocationDetail | optional pre-allocated detail to populate and return. |
Returns - undefined | CurveLocationDetail
details of the closest point.
Defined in
- curve/CurveCollection.ts Line 471
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.