Vector3dArray Class
The Vector3dArray
class contains static methods that act on arrays of 3d vectors.
Methods
Name | Description | |
---|---|---|
constructor(): Vector3dArray | ||
cloneVector3dArray(data: Readonly<WritableXYAndZ>[]): Vector3d[] Static | Return an array containing clones of the Vector3d data[] | |
isAlmostEqual(dataA: Vector3d[], dataB: Vector3d[]): boolean Static | Return true if arrays have same length and matching coordinates. |
Defined in
- geometry3d/PointHelpers.ts Line 361
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.