isAlmostEqual Method
Test for nearly equal Ray3d objects.
- This tests for near equality of origin and direction -- i.e. member-by-member comparison.
- Use isAlmostEqualPointSet to allow origins to be anywhere along the common ray and to have to allow the directions to be scaled or opposing.
isAlmostEqual(other: Ray3d): boolean
Parameter | Type | Description |
---|---|---|
other | Ray3d |
Returns - boolean
Defined in
- geometry3d/Ray3d.ts Line 77
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.