createRigidHeadsUp MethodStatic
Construct a rigid matrix (orthogonal matrix with determinant 1) using vectorA and its 2 perpendiculars.
- If axisOrder is not passed then
AxisOrder = AxisOrder.ZXY
is used as default. - This function internally uses createPerpendicularVectorFavorXYPlane and createRigidFromColumns.
- Passing the normal of a plane P into this method returns a matrix whose transpose rotates geometry in P to the xy-plane if P contains the origin, or to a plane parallel to the xy-plane if P does not contain the origin.
- Visualization can be found at https://www.itwinjs.org/sandbox/SaeedTorabi/2PerpendicularVectorsTo1Vector
createRigidHeadsUp(vectorA: Vector3d, axisOrder: AxisOrderAxisOrder.ZXY, result?: Matrix3d): Matrix3d
Parameter | Type | Description |
---|---|---|
vectorA | Vector3d | |
axisOrder | AxisOrder | |
result | Matrix3d |
Returns - Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 730
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.