solveTrigForm MethodStatic
Return solution(s) of equation constCoff + cosCoff*c + sinCoff*s = 0
for c
and s
with the
constraint c*c + s*s = 1
.
- There could be 0, 1, or 2 solutions. Return
undefined
if there is no solution.
solveTrigForm(constCoff: number, cosCoff: number, sinCoff: number): undefined | Vector2d[]
Parameter | Type | Description |
---|---|---|
constCoff | number | |
cosCoff | number | |
sinCoff | number |
Returns - undefined | Vector2d[]
Defined in
- Geometry.ts Line 1041
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.