axisOrderToAxis MethodStatic
Given an axisOrder
(e.g. XYZ, YZX, etc) and an index
, return the axis
at the given index.
- For example, if
axisOrder = XYZ
, then for index 0 returnX
(or axis 0), for index 1 returnY
(or axis 1), and for index 2 returnZ
(or axis 2). - Another example: if
axisOrder = ZXY
, then for index 0 returnZ
(or axis 2), for index 1 returnX
(or axis 0), and for index 2 returnY
(or axis 1). - For indexes greater than 2 or smaller than 0, it return cyclic axis. See cyclic3dAxis for more info.
axisOrderToAxis(order: AxisOrder, index: number): number
Parameter | Type | Description |
---|---|---|
order | AxisOrder | |
index | number |
Returns - number
Defined in
- Geometry.ts Line 958
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.