BooleanClipFactory Class
A BooleanClipFactory is a factory to create objects that implement interior nodes of a tree of boolean clip operations.
- These methods create specific clip tree types:
- Union
- Intersection
- Parity
- Difference
- Each construction has a
keepInside
flag that optionally negates the initial result of the parity, intersection, parity, or difference:- if
keepInside === true
, accept the "inside" of the initial result. - if
keepInside === false
, accept the "outside" of the initial result.
- if
- These methods create various other specialized clippers.
Methods
Name | Description | |
---|---|---|
constructor(): BooleanClipFactory | ||
anyClipperToJSON(clipper: any): any Static | Choose a toJSON method appropriate to the clipper |
|
createCaptureClipOutside(primaryClipper: Clipper): Clipper Static | Create a boolean clipper which performs the reverse of that of primaryClipper . |
|
createCaptureDifference(primaryClipper: Clipper, excludedClipper: Clipper, keepInside: boolean): Clipper Static | Create a boolean clipper which performs a difference operation for points "inside primaryClipper " and |
|
createCaptureIntersection(clippers: Clipper | Clipper[], keepInside: boolean): Clipper Static | Create a boolean clipper which performs an intersection over its children. | |
createCaptureParity(clippers: Clipper | Clipper[], keepInside: boolean): Clipper Static | Create a boolean clipper which performs a parity over its children. | |
createCaptureUnion(clippers: Clipper | Clipper[], keepInside: boolean): Clipper Static | Create a boolean clipper which performs a union over its children. | |
parseToClipper(source?: object): undefined | Clipper Static | Look for content that represents a clipper. | |
parseToClipperArray(source: any): undefined | Clipper[] Static | Convert source to an array of clipper objects. |
Defined in
- clipping/BooleanClipFactory.ts Line 29
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.