testClosablePolygon Method
Test if the leading and trailing poles are replicated in the manner of a "closed" B-spline function with wraparound control polygon.
testClosablePolygon(mode?: BSplineWrapMode): boolean
@returns true if the expected leading and trailing poles match, according to mode
.
Parameter | Type | Description |
---|---|---|
mode | BSplineWrapMode | wrap mode, indicating the number of wraparound poles to check. If undefined, knots.wrappable is used. |
Returns - boolean
true if the expected leading and trailing poles match, according to mode
.
Defined in
- bspline/BSpline1dNd.ts Line 233
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.