linearCombination Method
Compute the linear combination s of the indexed p_i and given scales s_i.
linearCombination(scales: number[], result?: Vector2d | Point2d): XY
@returns s = sum(p_i * s_i), where i ranges from 0 to min(this.length, scales.length).
Parameter | Type | Description |
---|---|---|
scales | number[] | array of scales. For best results, scales should have same length as the instance. |
result | Vector2d | Point2d | optional pre-allocated object to fill and return |
Returns - XY
s = sum(p_i * s_i), where i ranges from 0 to min(this.length, scales.length).
Defined in
- geometry3d/IndexedXYCollection.ts Line 105
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.