insetByPercent Method
Inset this ViewRect by a percentage of its current width.
insetByPercent(percent: number): void
@note The ViewRect will become smaller (or larger, if percent is negative) by percent * width * 2
in each direction, since each side is moved by that distance.
@see inset
Parameter | Type | Description |
---|---|---|
percent | number | The percentage of this ViewRect's width to inset in all directions. |
Returns - void
Defined in
- core/frontend/src/common/ViewRect.ts Line 136
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.