zoomToPlacements Method
Zoom the view in or out to a fit to the tightest volume enclosing a given set of placements, optionally also changing the view rotation.
zoomToPlacements(placements: Placement[], options?: ViewChangeOptions & MarginOptions & ZoomToOptions): void
@note any invalid placements are ignored. If no valid placements are supplied, this function does nothing.
@see - zoomToElements to zoom to a set of elements.
- IModelConnection.Elements.getPlacements to obtain the placements for a set of elements.
Parameter | Type | Description |
---|---|---|
placements | Placement[] | The array of placements. The view will zoom to fit the union of the placements. |
options | ViewChangeOptions & MarginOptions & ZoomToOptions | Options controlling how the view change works and whether to change view rotation. |
Returns - void
Defined in
- core/frontend/src/Viewport.ts Line 2130
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.