ZoomToOptions Interface
Options to allow changing the view rotation with zoomTo methods and ensure minimum bounding box dimensions for zoomToElements.
Properties
Name | Type | Description | |
---|---|---|---|
minimumDimension | number | undefined | Ensure minimum element-aligned bounding box dimensions in meters (3d only). | |
placementRelativeId | StandardViewId | undefined | Set view rotation relative to placement of first element or props entry. | |
standardViewId | StandardViewId | undefined | Set view rotation from standard view identifier. | |
viewRotation | Matrix3d | undefined | Set view rotation from Matrix3d. |
Defined in
- core/frontend/src/Viewport.ts Line 141
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.