screenSpaceEffects
Getter
An ordered list of names of screen-space post-processing effects to be applied to the image rendered by the Viewport. The effects are applied to the image in the order in which they appear in the list. Any names not corresponding to a registered effect are ignored. This may have no effect if the Viewport's RenderTarget does not support screen-space effects.
screenSpaceEffects: Iterable<string, any, any>
@see createScreenSpaceEffectBuilder to create and register new effects.
Returns - Iterable<string, any, any>
Setter
screenSpaceEffects(effects: Iterable<string, any, any>): void
Parameter | Type | Description |
---|---|---|
effects | Iterable<string, any, any> |
Returns - void
Defined in
- core/frontend/src/Viewport.ts Line 2899
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.