invalidateController Method
Mark the viewport's ViewState as having changed, so that the next call to renderFrame will invoke setupFromView to synchronize with the view. This method is not typically invoked directly - the controller is automatically invalidated in response to events such as a call to changeView. Additionally, refresh the Reality Tile Tree to reflect changes in the map layer.
invalidateController(): void
Returns - void
Defined in
- core/frontend/src/Viewport.ts Line 441
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.