getSubCategoryAppearance Method
Query the symbology with which geometry belonging to a specific subcategory is rendered within this viewport. Every SubCategory defines a base symbology independent of any Viewport. If a SubCategoryOverride has been applied to the subcategory within the context of this Viewport, it will be applied to the subcategory's base symbology.
getSubCategoryAppearance(id: string): SubCategoryAppearance
@returns The symbology of the subcategory within this viewport, including any overrides.
@see overrideSubCategory
Parameter | Type | Description |
---|---|---|
id | string | The Id of the subcategory. |
Returns - SubCategoryAppearance
The symbology of the subcategory within this viewport, including any overrides.
Defined in
- core/frontend/src/Viewport.ts Line 714
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.