changeModelDisplay Method
Add or remove a set of models from those models currently displayed in this viewport.
changeModelDisplay(models: Id64Arg, display: boolean): boolean
@returns false if this Viewport is not viewing a SpatialViewState
@note This function only works if the viewport is viewing a SpatialViewState, otherwise it does nothing.
@note This function does not load any models. If display
is true
and any of the supplied models
refers to a model that has not been loaded, no graphics will be loaded+displayed in the viewport for that model.
@see addViewedModels for a similar function that also ensures the requested models are loaded.
Parameter | Type | Description |
---|---|---|
models | Id64Arg | |
display | boolean | Whether or not to display the specified models in the viewport. |
Returns - boolean
false if this Viewport is not viewing a SpatialViewState
Defined in
- core/frontend/src/Viewport.ts Line 987
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.