addViewedModels Method
Adds a set of models to the set of those currently displayed in this viewport.
addViewedModels(models: Id64Arg): Promise<void>
@note This function only works if the viewport is viewing a SpatialViewState, otherwise it does nothing.
@note If any of the requested models is not yet loaded this function will asynchronously load them before updating the set of displayed models.
Parameter | Type | Description |
---|---|---|
models | Id64Arg |
Returns - Promise
Defined in
- core/frontend/src/Viewport.ts Line 1005
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.