applyViewState Method
Replace this viewport's ViewState without triggering events like onChangeView. This is chiefly useful when you are synchronizing the states of two or more viewports, as in TwoWayViewportSync, to avoid triggering unwanted "echo" events during synchronization. In all other scenarios, changeView is the correct method to use.
applyViewState(val: ViewState): void
Parameter | Type | Description |
---|---|---|
val | ViewState |
Returns - void
Defined in
- core/frontend/src/Viewport.ts Line 2245
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.