animateFrustumChange Method
Queue an animation that interpolates between this viewport's previous Frustum and its current frustum. This function is typically called by ViewTools after modifying the viewport's ViewState, to smoothly transition to the new view; as opposed to calling synchWithView which immediately transitions to the new view. It uses FrustumAnimator to perform the animation.
animateFrustumChange(options?: ViewAnimationOptions): void
Parameter | Type | Description |
---|---|---|
options | ViewAnimationOptions |
Returns - void
Defined in
- core/frontend/src/Viewport.ts Line 3386
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.