MutableChangeFlags Class
A ChangeFlags that permits modifying the states of individual ChangeFlags.
Extends
Methods
Name | Description | |
---|---|---|
constructor(flags: ChangeFlagChangeFlag.Initial): MutableChangeFlags | Create a new MutableChangeFlags. | |
clear(flags: ChangeFlagChangeFlag.All): void | Clear all of the specified flags. | |
setAlwaysDrawn(): void | ||
setDisplayStyle(): void | ||
setFeatureOverrideProvider(): void | ||
setNeverDrawn(): void | ||
setViewedCategories(): void | ||
setViewedCategoriesPerModel(): void | ||
setViewedModels(): void | ||
setViewState(): void |
Inherited methods
Name | Inherited from | Description |
---|---|---|
areAllSet(flags: ChangeFlag): boolean Inherited | ChangeFlags | Returns true if all of the specified flags are set. |
isSet(flags: ChangeFlag): boolean Inherited | ChangeFlags | Returns true if any of the specified flags are set. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_flags Protected Inherited | ChangeFlag | ChangeFlags | The bitmask that records the state of each individual flag. |
alwaysDrawn Accessor Inherited ReadOnly | boolean | ChangeFlags | The set of always-drawn elements has changed. |
areFeatureOverridesDirty Accessor Inherited ReadOnly | boolean | ChangeFlags | Returns true if any aspects affecting Overrides have changed. |
displayStyle Accessor Inherited ReadOnly | boolean | ChangeFlags | The DisplayStyleState or its settings such as ViewFlags have changed. |
featureOverrideProvider Accessor Inherited ReadOnly | boolean | ChangeFlags | The FeatureOverrideProvider has changed, or its internal state has changed such that its overrides must be recomputed. |
hasChanges Accessor Inherited ReadOnly | boolean | ChangeFlags | Returns true if any aspect at all has changed. |
neverDrawn Accessor Inherited ReadOnly | boolean | ChangeFlags | The set of never-drawn elements has changed. |
value Accessor Inherited ReadOnly | ChangeFlag | ChangeFlags | The underlying bitmask indicating the state of each individual flag. |
viewedCategories Accessor Inherited ReadOnly | boolean | ChangeFlags | The set of displayed categories defined by the viewport's CategorySelectorState has changed. |
viewedCategoriesPerModel Accessor Inherited ReadOnly | boolean | ChangeFlags | The Overrides associated with the viewport have changed. |
viewedModels Accessor Inherited ReadOnly | boolean | ChangeFlags | The set of models to be displayed in the viewport has changed. |
viewState Accessor Inherited ReadOnly | boolean | ChangeFlags | Vewport.changeView was used to replace the previous ViewState with a new one. |
Defined in
- core/frontend/src/ChangeFlags.ts Line 107
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.