Cluster<T extends Marker> Class
A cluster of one or more Markers that overlap one another in the view. The cluster's screen position is taken from its first entry. Clusters also have a Marker themselves, that represents the whole group. The cluster marker isn't created until all entries have been added.
Methods
Name | Description | |
---|---|---|
constructor<T extends Marker>(markers: T[]): Cluster<T> | ||
getClusterLocation(): Point3d | Gets the location for the cluster |
Properties
Name | Type | Description | |
---|---|---|---|
clusterMarker | Marker | undefined | ||
markers Readonly | T[] | ||
position Accessor ReadOnly | Point3d |
Defined in
- core/frontend/src/Marker.ts Line 325
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.