filterHit Method
Invoked to allow tools to filter which elements can be located.
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus>
@returns Reject if hit is unacceptable for this tool (fill out response with explanation, if it is defined)
Parameter | Type | Description |
---|---|---|
_hit | HitDetail | |
_out | LocateResponse |
Returns - Promise<LocateFilterStatus>
Reject if hit is unacceptable for this tool (fill out response with explanation, if it is defined)
Defined in
- core/frontend/src/tools/Tool.ts Line 681
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.