FuzzySearchResults<T> Class
This class is used to return the results of FuzzySearch.search. It is iterable, with each iteration returning an object implementing the FuzzySearchResult interface.
Implements
- Iterable<T>
Methods
Name | Description | |
---|---|---|
constructor<T>(results: any[]): FuzzySearchResults<T> | ||
[iterator](): any | ||
getResult(resultIndex: number): undefined | FuzzySearchResult<T> |
Properties
Name | Type | Description | |
---|---|---|---|
length Accessor ReadOnly | number | ||
results | any[] |
Defined in
- core/frontend/src/FuzzySearch.ts Line 177
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.