getToolTip Method
Return a tooltip describing the hit, or undefined
if no tooltip can be supplied.
If you override this method, make sure to check that hit
represents an entity belonging to your tile tree, e.g., by checking hit.modelId
and hit.sourceId
.
If you don't override this method, override canSupplyToolTip to return false.
Callers who want to obtain a tooltip should prefer getToolTipPromise.
getToolTip(_hit: HitDetail): Promise<undefined | string | HTMLElement>
Parameter | Type | Description |
---|---|---|
_hit | HitDetail |
Returns - Promise<undefined | string | HTMLElement>
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.