getNameFromUrl MethodStatic
Extract the host name from a URL for use as the name of the corresponding TileRequestChannel.
getNameFromUrl(url: string | URL): string
@throws TypeError if url
is a string and does not represent a valid URL.
@see getForHttp to obtain or register a channel for the host name.
Parameter | Type | Description |
---|---|---|
url | string | URL |
Returns - string
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.