readGltfGraphics Function
Produce a RenderGraphic from a glTF asset suitable for use in view decorations.
readGltfGraphics(args: ReadGltfGraphicsArgs): Promise<RenderGraphic | undefined>
@returns a graphic produced from the glTF asset's default scene, or undefined
if a graphic could not be produced from the asset.
@see readGltf for more details.
Parameter | Type | Description |
---|---|---|
args | ReadGltfGraphicsArgs |
Returns - Promise<RenderGraphic | undefined>
a graphic produced from the glTF asset's default scene, or undefined
if a graphic could not be produced from the asset.
Defined in
- core/frontend/src/tile/GltfReader.ts Line 2169
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.