loadTexture Method
Find or create a RenderTexture from a persistent texture element.
loadTexture(id: string, iModel: IModelConnection): Promise<undefined | RenderTexture>
@returns A Promise resolving to the created RenderTexture or to undefined if the texture could not be created.
@note If the texture is successfully created, it will be cached on the IModelConnection such that it can later be retrieved by its ID using findTexture.
@see loadTextureImage.
Parameter | Type | Description |
---|---|---|
id | string | The ID of the texture element. |
iModel | IModelConnection | The IModel containing the texture element. |
Returns - Promise<undefined | RenderTexture>
A Promise resolving to the created RenderTexture or to undefined if the texture could not be created.
Defined in
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.