findMaterial Method
Find a previously-created RenderMaterial by its ID.
findMaterial(_key: string, _imodel: IModelConnection): undefined | RenderMaterial
@returns A previously-created material matching the specified ID, or undefined if no such material exists.
Parameter | Type | Description |
---|---|---|
_key | string | The unique ID of the material within the context of the IModelConnection. Typically an element ID. |
_imodel | IModelConnection | The IModelConnection with which the material is associated. |
Returns - undefined | RenderMaterial
A previously-created material matching the specified ID, or undefined if no such material exists.
Defined in
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.